0

I've built a simple proof-of-concept app on a Trailhead Playground. I'm trying to move it to a Developer Sandbox. I've got my package.xml file sending metadata to the sandbox, but I'm missing a few pieces. Specifically, the app doesn't have the the System Administrator user profile selected and the app page showing up (although the activation dialog shows it's attached to the app).

I've searched through the Metadata Coverage Report looking for the types that might cover app user profiles and page activation without any luck. How do I figure out which metadata to retrieve from an org so that when I deploy it to another org it just works?

1
  • specify <members>Admin</members> profile in your manifest file
    – jm.
    Commented Apr 8, 2021 at 19:04

1 Answer 1

1

You can retrieve your custom metadata and the Admin profile at once, and the relevant permissions should be retrieved; the Profile file has the settings you want.

<?xml version="1.0"encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata"
<types>
  <members>*</members>
  <name>Profile</name>
</types>
<!-- your other package.xml types -->
<version>51.0</version>
</Package>

This is required by the Metadata to minimize the number of permissions that are retrieved (which makes it easier to port relevant permissions without getting everything in a profile).

2
  • I added the Profile type to my manifest and the retrieve feature brought in 36 profiles, most of which caused error, but didn't actually get the one I wanted, System Administrator. Do I need to assign some test profile to the app instead?
    – Chuck
    Commented Apr 8, 2021 at 18:39
  • @Chuck System Administrator is just called Admin in the file listing.
    – sfdcfox
    Commented Apr 8, 2021 at 19:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .