2

I have a user who is not able to delete accounts. The delete menu button is available to them, and the "Delete Account" dialog appears for them, but when they click Delete it shows this error:

There's a problem saving this record. You might not have permission to edit it, or it might have been deleted or archived. Contact your administrator for help.

The user's profile has the Object Permissions for Accounts set to "Read, Create, Edit, Delete, View All". My understanding is that the Delete permission here is what makes the delete menu option visible to the user.

As an administrator I am able to delete the account without any problems.

Any ideas what is going wrong here, or how I could see more specifically what permission SF thinks the user needs that they don't have?

13
  • Enable Debug logging for this user, open dev console, uncheck 'show my current logs', get them to try to delete and inspect the log
    – zaitsman
    Apr 7, 2021 at 5:59
  • the issue also might be with Apex Triggers, if there code tries to access records that this user doesn't have rights to.
    – ytiq
    Apr 7, 2021 at 6:12
  • @zaitsman Thanks for the idea, however nothing's coming up in the log. Any idea what DebugLevel settings would show something useful? Apr 7, 2021 at 6:12
  • When you say nothing's coming up in the log do you actually get the log for THIS user (not your name) and does it show the delete attempt?
    – zaitsman
    Apr 7, 2021 at 6:12
  • @zaitsman I see for the other user an "/apex/NPSP_Home" Operation, but nothing about the delete attempt. I found a Mailchimp apex trigger which I'm going to try to disable. Apr 7, 2021 at 6:15

4 Answers 4

1

The ability to delete records in Salesforce is controlled by the role hierarchy.

Beyond confirming they have CRED permissions, make sure they're either the record owner, above the record owner in the role hierarchy, or they have modify all permission for accounts.

See this Salesforce help article

0

A bit old but I hope my experience to help somebody.

If permissions are properly set, then it is probably a trigger preventing deletion. Or perhaps an error in the trigger.

In both cases there should be a trace in the log. If there is nothing in the log try LMA - there is a chance errors to come from a managed package doing something when delete event is triggered.

HTH

0

I ran into this issue. User had correct CRUD permissions and was able to edit the record but received this error on delete. I set up debug log and know trace logs showing when attempting to delete, just the error message. I found that it was because the person attempting to delete was a lateral Role as the Owner's manager in the Role hierarchy and not directly higher than the Owner in the Role Hierarchy. The workaround was to have them change the Owner to themself and then Delete and that worked in my situation.

-1

Same Issue Happened With Me I have notice If there are any associate records Such as Contact this issue Will Happen if you Remove or delete this associate Records! you will be able to delete account Without any error!

1
  • 1
    If this were the issue here, OP wouldn't have been able to delete the record themselves.
    – Derek F
    Nov 26, 2022 at 13:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .