0

sfdx push a fake class to scratch org is returning no results found. I have a scratch org built on production org shape. Here is the list of actions I tried,

  1. sfdx deploy first followed by creating a fake class then issue sfdx force:source:push
  2. downgrade sfdx-cli version from the latest to 7.85.
  3. sfdx force:source:pull --json first and then push.
  4. sfdx deploy will deploy the fake class. But that is not what I want to achieve.
  5. tried both the npm and windows versions of the cli
  6. tried on many scratch orgs.
  7. issue the sfdx push in vscode terminal PS/Bash and windows command prompt
  8. sfdx force:source:status --json showing the installed items

the result from all the above is

sfdx force:source:push --json
{
  "status": 0,
  "result": {
    "pushedSource": []
  }
}
2
  • 1
    Your question is confusing. What exactly are you hoping to achieve? – sfdcfox Apr 2 at 14:29
  • @sfdcfox I am trying to sfdx push new classes to scratch org but sfdx is saying no results found, as it is shown in the code snippet, pushedSource is empty when I clearly have have created a class and trying to push. I am saying sfdx force:source:push is not working and I have no idea what to troubleshoot. – Mo Ali Apr 2 at 16:42
0

After long hours trail and error, I figured out that I missed out sourceOrg Id in project-scratch-def.json

"sourceOrg": "You production org shape Id", following this Limitations for Org Shape (Beta) now I am able to do incremental push to scratch org

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.