1

For the Experience Site that I am currently building, I want to show a preview of a several layouts which will encourage the guest to sign up. This preview is supposed to be a limited set of fields of what's on the main layout.

I built a layout, find that when I go to assign the layout to the Guest User - the Guest User Profile is not visible.

I also know that to access to the Guest User Profile, I can get to it from the Experience Builder here:

enter image description here

However again, when I'm on this profile and click assign layouts from here:

enter image description here

Again, I'm just back at the regular layout assignment area - with no sign of the Guest Profile at all.

So my questions:

  • Is it possible to assign a layout to the guest profile.
  • What layout DOES it actually use (something definitely shows up, but I'm really not sure which one)
0

1 Answer 1

5

I assume you are using Lightning experience to view the "Page Layout Assignment".

I could reproduce the behavior you mentioned i.e., Page Layout Assignment doesn't show the Guest user's profile on my org too in LEX. However, when I switched to the classic view, I could find the Guest user's profile which in my case is named "Napili Site Profile" and edit the layout. That did the trick!

Click path: Switch to Classic > From Setup > All sites> click Builder next to "Napili Site" > Settings > General > select “Napili Site Profile” under Guest User Profile> View Assignment

Attaching screenshots: Classic Classic

Lightning Experience Lightning Experience

Not sure if this is a bug. I will reach out to our concerned product team and update this thread as I have more inputs.

3
  • Yes, this is indeed the case - from lightning, you cannot access the Guest Profile. From Classic, you can. How did you figure this out?? Apr 3, 2021 at 20:52
  • 1
    I saw a similar issue in the past based on which I checked in classic and LEX. 😊 Apr 4, 2021 at 7:56
  • 3
    this workaround is no longer required. Page Layout assignments are available via LEX Setup -> Sites -> your site -> Public Access Settings -> Object Settings -> your object
    – cropredy
    Feb 11, 2023 at 0:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .