1

I'm doing a tutorial on communities, and after setting pages and themes, i wanted to add users. When i try to setup the user, i get this message: "Looks like this portal user is not a member of a experience".

The access is made from the contact object, so the related user has this configuration:

Profile = Customer Community User
Active = true

when in the community layout, i went to top ledt corner, with my system Administrator user, and all the buttons: Builder, moderation, Administration, take me to a login page. I tried with my user, but the password is invalid, so i guess that means i should either use this community user, or adding my own to that community.

I also seen you can do this adding permission settings, so i activate the ones i could find related:

View Content in Portals
Manage Users
Manage Customer Users

The configured expedience is there, and i can open the builder link enter image description here

on the top-left button, i can click on Builder, wich takes me to the to where i can edit Themes and pages. That works well

But all the buttons below take to this url:

this be a security risk? well, its a developer org...)

http://[site URL]/darthdaderiscool/login?ec=302&inst=5J&startURL=%2Fdarthvaderiscool%2FcommunitySetup%2FcwApp.app%23/c/page/dashboardManagementHome

site URL = the same i find in the setup > Sites > All sites
darthvaderiscool = url of that community
url parameters = url parameter that follow, i show them bellow (would showing 

7 links, only the first works

All those 6 links take me to this same login page:

login page

I'm using classic, and its a developer org. The result is exacty the same, with classic and Lightning. So, if adding users to a community is done in that Administrator link, and to that i need to access the community, with a community User, this is a circular problem. How can i add any user that user to the community?

2

Access to a community is based on the assignment of one or more profiles to the community. Any user that is using one of those profiles has access.

Make this assignment by clicking on the "Workspaces" link then on the "Administration" tile then on the "Members" tab, and adding one or more profiles:

Members tab

Note: do not remove the "System Administrator" from the list. If you do, you will not longer be able to modify the community.

Somewhat related, you can also configure the profile that self-registering users are given via the "Login & Registration" tab:

Login & Registration tab

Edit by Luis:

I now add these priveges in a permission set, to my System Administrator User:

System Permissions >

Lightning Experience User
Manage Users
Salesforce Anywhere in Lightning Experience 
Lightning Experience User   
Lightning Login User
Create and Set Up Experiences   
Manage Experiences  
Skip Device Activation at Login 
Access Experience Management    

App Permissions >

Manage Customer Users
Manage Published Solutions
Manage Content Permissions  
Manage Content Properties
Manage Salesforce Knowledge 
View Content in Portals 
9
  • Thanks for the reply. And what you mention is the problem: i can't access that "Administration" page, or the "Login & Registration" from there. I'm always asked for a login, that i assume is of an access, provided from the user associated with the contact. I thought to access it, i would need to grant that permission to the System Administration profile. I did, and the results are as described. I don't know where else to look – Luis Aguiar Mar 21 at 19:51
  • I wonder if you have a permission set that grants access to the community assigned to you? It could then be possible that it thinks you are a user, rather than an admin of the community. Also, check that your sys admin profile is allowed to administer communities. – Caspar Harmer Mar 21 at 20:32
  • Afterwards, I also disabled all the verifications regarding communities, and chatter. To no avail so far – Luis Aguiar Mar 21 at 20:33
  • Uncheck "allow employees to login directly" on the page shown in the picture directly above – Caspar Harmer Mar 21 at 20:34
  • 1
    @LuisAguiar You may have run into the problem that your profile is not listed in the "Selected Profiles" - see the first screen shot I added. Did someone else create the community who has a different profile than you? Get them to add your profile. (There are other ways round this - see e.g. wedgecommerce.com/faqs-regarding-salesforce-communities/.) – Keith C Mar 21 at 21:56
0

The solution, as in many salesforce things was simple: forget the problem, remake it all over - for the 3rd time. Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.