4

I got the following error message when uploading a new patch version of my managed package:

An unexpected error occurred when uploading your package. 
Please contact Salesforce Support and provide the following error code: 1898781269-33015 (1917262905)

I am able to upload the exact same package as a Managed - Beta version, error occurs only when uploading as Managed - Released. I was also able to upload a previous Managed - Released patch from the same org a week or so ago.

Partner support pointed me to this known issue: https://success.salesforce.com/issues_view?id=a1p30000000T0y2AAC. I have not yet tried the suggested workaround of downgrading to API version 16. It seems a pretty drastic step and it may not even be possible with my app.

Before I go that route I'm hoping someone here has a better solution...

[Update]: I worked around the issue the first time by creating a new major release and a clean patch org. But now a similar issue has surfaced there as well, although with a different error code: 310161302-57381 (635022129)

Additional data point: it seems the upload breaks during the Creating a snapshot of package components phase, after all the tests have run. As before, everything works fine when uploading as Managed - Beta, only the Managed - Released update fails

  • The workaround with the API version seems to me for a completly different problem. I had these errors several times and most times only salesforce could fix it. Mostly it occurred when we had deactivated or deleted something should have not. – Frederik Apr 25 '14 at 7:07
3

Error codes of that nature indicate than an exception was thrown in the underlying application server that Salesforce runs on and was not trapped by any exception handlers. You'll need Salesforce (probably R&D) to investigate this for you as only they have access to the underlying logs and code. I've gained access to the log snippets before through some of my SFDC contacts, but it doesn't help without being able to see the code, and even if by some miracle I could spot the problem there's nothing I can do to fix it.

I'd be inclined to ask support if they have confirmed that the error that you are seeing is definitely caused by the known issue - otherwise its a pretty drastic change to have to make and I'd expect a few gotchas with downgrading to API v16. The last time I hit this type of issue with a managed package it was a bug in the packaging code that required a release to fix.

1

Salesforce support helped figure out the problem for the second occurrence of this problem: I had added a getter and setter to a global property, changing:

global <type> globalProp = null;

to

global <type> globalProp{
        get {...}  
        set {...}
    }

This compiled fine and didn't create any problems when uploading as 'Managed - Beta', but failed for 'Managed - Released'.

After removing the new getter and setter, the problem went away and I could upload my patch successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.