2

I'm experiencing a strange phenomenon in which errors (I believe compile errors) are no longer being picked up by the VS Code SFDX code. Normally when I run "SFDX: Deploy this source to org", it checks for errors and the deployment fails if any are found. But sometime today that stopped.

As an example, I ran confsdfsole.log("test"); instead of console.log("test");, and it deployed without issue.

Does anyone know how to turn error checking back on?

Edit: Things I have tried

  • Re-running npm install
  • Uninstalling and reinstalling the Salesforce Extension Pack
2
  • I tested versions of sfdx-cli up to about a month ago, none of them complain about this problem. Maybe you had a plugin that was checking for additional problems? I would try npm install in your project folder to make sure all of the relevant plugins are installed. – sfdcfox Mar 4 at 4:56
  • @sfdcfox just gave that a try, unfortunately it did not resolve the issue – Jwok Mar 4 at 16:03
2

I was able to determine the issue. For some reason the ESLint feature of the Salesforce Extension Pack was disabled. I noticed in the bottom-right corner of the screen the ESLINT icon in red with a cross-out circle next to it (image 1 below). I clicked on it and received a pop-up window that gave me the option to allow ESLint for the project (image 2 below). I clicked "Allow Everywhere" and the error catching was restored.

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.