0
<aura:component >
    <aura:attribute name="item" type="Camping_Item__c" required="true"/>
    <p>Name:{!v.item.Name}</p>
    <p>Price:
    <lightning:formattedNumber value="{!v.item.Price__c}" style="currency"/>
    </p>
    <p>Quantity:
        <lightning:formattedNumber value="{!v.item.Quantity__c}" style="number"/>
    </p>
    <p>
        <lightning:input type="toggle"
                         label="Packed?"
                         name="Packed"
                         checked="{!v.item.Packed__c}"/>                         
    </p>
</aura:component>

While saving this code i am getting this error

enter image description here

And After that while checking challenge it's showing : The campingListItem Lightning Component's attribute tag doesn't exist or its attributes are not set correctly.

3
  • Did you create the Camping_Item__c object?
    – sfdcfox
    Commented Feb 22, 2021 at 5:10
  • Yes, I created . Commented Feb 22, 2021 at 5:29
  • 1
    I'm not sure about this, but it would be a good idea to check that you have the case of Camping_Item__c correct. Apex is not case sensitive, but Javascript is. Also check your profile to make sure you have access to this object. Commented Feb 22, 2021 at 17:22

1 Answer 1

0

try to give a default=' ' because you have required is true for item attribute.

3
  • I tried default=' ' as you said . Still I got same problem . Commented Feb 22, 2021 at 17:58
  • Beside what @Caspar Harmer said, copy the API name of your object just to be sure.
    – Shahid
    Commented Feb 24, 2021 at 0:54
  • Thank you guys I solved my question. Commented Mar 3, 2021 at 11:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .