I've a Custom Object, and it has 3 RecordTypes. In my app, I've added an override for the "New" action link with a Visualforce Page.

Now in app (from desktop browser) the New button redirects and open RecordType wizard first, and then when clicked COntinue on screen, it opens my VF page.

In Salesforce1 app, when New button is clicked, it opens RecordType selection wizard page, but when clicked Continue, it opens my VF page "without" passing any RecordType selection value in the URL.

How do we tackle this in Salesforce1? I read the documentations, it says Link Overrides does not work in Salesforce1, but then why does it open our override when we clicked New button? I though since overrides are not supported in Salesforce1, it will simply detect and open Standard New interface part of Salesforce1 interface automatically.

Can anyone here suggest how to I make my New button work efficiently in both environments?

  • anyone here has some suggestions for this please? :( – VarunC Apr 29 '14 at 13:11
  • Hello @VarunC, Have you found a solution for this problem? – Robertinho Sedinho Jan 21 '15 at 9:53
  • no, still stuck on the same issue here, no resolution whatsoever :( ... – VarunC Jan 22 '15 at 8:10

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.