I am facing the below error

Exception Details: Update failed. First exception on row 0 with id *************; first error: TEMPLATE_NOT_FOUND, The record couldn't be saved because it triggered an email alert that failed. Please contact salesforce.com Customer Support.: []

The scenario is that we have a WF Rule on the Invoice object which fires the Email Alert after Registration. The Invoice Template is a VF Page. I researched for it and most of the folks suggest checking the permissions of the fields referenced in the Email template. I do that but still, I am getting the same error.

It's the second time I am facing this particular issue. The first time it was resolved by giving permission to a new field added on the Invoice object. But this time it happens suddenly without adding any new field.

Please suggest a way to resolve it Thanks.


This error may be related to the Spring '21 release that has been rolling out. They have changed the permissions granted to a Site Guest user. You may find that your email template, the one 'not found', may be trying to access a formula field on another object that the site user does not have permissions to.

I had tried granting permissions to the object and the field the formula field referenced, but this did not resolve the issue for me. For reference, I also tried creating a custom controller that would access the fields without the sharing permissions, but that didn't work either.

Not the answer you're looking for? Browse other questions tagged or ask your own question.