9

We're currently facing issues with deployments of a Experience Cloud Site using the ExperienceBundle metadata. We can retrieve a Experience Site using the ExperienceBundle Metadata type. When we deploy the bundle to the same Sandbox we used to retrieve it, we get the following deployment issues:

=== Deploy Errors
PROJECT PATH                                                              ERRORS                                                                                                                                                                                                                                                                                                                                                                                             

The reportId property of component xxxxx references an object with the ID value xxxxx. Occasionally, when deployed to a destination org, ID values can become invalid—for example, if the referenced ID doesn’t exist in the destination org. If you encounter component issues in your destination org, verify that the ID values are correct. (0:0)  

It seems that the report is not available with this id - but it is. Does anyone have a solution how we can fix this?

Update

I was experimenting with it and recognized the following behaviour. If you have a component like a record list on a page in the experience builder you have to specify the object and the filter for the record list.

When you retrieve the Experience bundle from your org, you will find the ID of the specified filter in the property "filterName". You will not be able to deploy this bundle anywhere, not even to the same org you have retrieved it from, because the filterName should in fact be the name of the filter e.g. "allOpenCases". You can replace the ID with the filter name and deploy it succesfully. But next time you retrieve it, it will again be replaced by the ID.

So for me - until now the experience bundle is unusable.

2
  • 1
    Using the ExperienceBundle is... definitely an experience I would not like to repeat. Feb 24, 2021 at 1:26
  • I recommend you move your update to be an answer to your own question...
    – Phil W
    May 28, 2021 at 8:11

2 Answers 2

15

Update

I was experimenting with it and recognized the following behaviour. If you have a component like a record list on a page in the experience builder you have to specify the object and the filter for the record list. When you retrieve the Experience bundle from your org, you will find the ID of the specified filter in the property "filterName". You will not be able to deploy this bundle anywhere, not even to the same org you have retrieved it from, because the filterName should in fact be the name of the filter e.g. "allOpenCases". You can replace the ID with the filter name and deploy it succesfully. But next time you retrieve it, it will again be replaced by the ID.

So for me - until now the experience bundle is unusable.

1
  • 1
    This works for List Views (the "filterName" property), but what about Dashboards? I'm not having any luck getting a Dashboard component in an Experience Bundle page to deploy. The failing property is "recordId", and it doesn't seem to work even after updating the value to the ID of the Dashboard that was previously deployed into the destination org. Any experience with this same issue, but for Dashboard components? Nov 18, 2021 at 16:57
3

According to the documentation, you shouldn't reference to a specific Object Id, but instead use the developer name:

If you create a custom component with an attribute that references a Salesforce object, use the object’s developer name as the attribute value and not the object’s ID.

Documentation:

https://developer.salesforce.com/blogs/2020/02/experiencebundle-salesforce-dx-a-developers-dream-for-coding-lighting-communities.html

1
  • Hi Jeroen, thanks for this. Anyway, if you for example add a report to an experience builder page the report is added with it's id. The strange thing is that the report should be available with exactly this id as the experience bundle was retrieved from the same org where I try to deploy it.
    – Chris.Walz
    Feb 16, 2021 at 17:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .