0

I am facing this issue, on an unmanaged package my Open CTI methods(Enable click to dial and screen pop) seem to work fine, but on a managed package it doesn't work.

Enable click to dial method:

var enableClickToDialcallback = function(response) 
{
     if (response.success) 
     {
        console.log('API method call executed successfully! returnValue:', response.returnValue);
     } 
     else 
     {
        console.log( 'Click to dial unsuccessful ' + response.errors);
         
     } 
  };

  function enableClickToDial() {
      sforce.opencti.enableClickToDial({callback: enableClickToDialcallback});
  }

Any help on this would be greatly appreciated.

7
  • Can you highlight any code which you think might be causing issue, or maybe share code part which is working in unmanaged package and you are expecting it to work in managed package as well. Feb 15 at 9:34
  • @itzmukeshy7 added the code in post for Enable Click to dial method.
    – Badar
    Feb 15 at 10:16
  • So you must be getting error in the errorThrown what is that? Feb 15 at 11:18
  • No errors, that's the issue.
    – Badar
    Feb 15 at 11:29
  • Anything we see in the console tab or network tab? Feb 15 at 12:50
0

I observed the issue was with my registered namespace. It contained underscore "_" in it. When I created a namespace in another org (both subscriber org and where I developed my package) with just camel case notation it worked fine. My open CTI methods started executing callbacks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.