0

I have a process builder set up to do the following on a custom object, Referral:

  1. If the custom field "Referred To" changes, update the Owner field to a queue (the queue id is dynamic based on criteria) --> Evaluate the next criteria -->
  2. When the Owner field changes, send a notification to the owner (a notification in the bell icon, not an email notification). If the owner is a queue, then all members in the queue are notified.

Here's what's puzzling me:

  • Part 1) works on its own. When I change the value in the Referred To field, it automatically updates the Owner field correctly.
  • BUT, notifications in Part 2) are not sent when Owner is updated via Part 1). And yes, I have it set to "Evaluate Next Criteria", so that's not the issue.
  • However, notifications in Part 2) are sent when I update the Owner manually via the record page.

Why do each of these work individually, but Part 1 doesn't trigger Part 2 ??? I've spent hours on trial and error trying to figure out what I'm doing wrong, but I can't figure it out.

Anyone have any idea what I need to fix?

4
  • I've done very little with Process Builder. Does it consider everything as one transaction? If so, the changes in Part 1 would not be updated in the database until the entire process was complete; thus Part 2 would not notice the changes in Part 1.
    – Moonpie
    Feb 11, 2021 at 2:08
  • 2
    Also: isn't there a selection somewhere to allow a process to re-evaluate the same record multiple times? If so, do you have that selected?
    – Moonpie
    Feb 11, 2021 at 2:12
  • @Moonpie - PB runs in same transaction as the DML that triggers it (except for any scheduled actions)
    – cropredy
    Feb 11, 2021 at 2:21
  • @Moonpie That was it, thank you!!
    – nfoley
    Feb 11, 2021 at 23:29

1 Answer 1

0

Fixed it - just had to enable the Allow Recursion option.

Credit to @Moonpie

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .