I want certain standard users to be able to load leads through workbench. The owner field is an external Id, thus I can't make them using Data Loader Upsert (only include custom reference fields)

I created a permission set to include the connect app - workbench, and all edit permission on lead object. They are able to login workbench, but when inserting records, they got the error shown below, it indicates that "View All Data" is the solution, but this is not acceptable by the management. Is there any workarounds on my situation?

enter image description here

1 Answer 1


The workaround is to use a Custom field as ExternalId and has the Unique attribute and the Treat "ABC" and "abc" as duplicate values (case insensitive) option selected.

This way you do not need the ViewAllData or ViewAllRecords permissions is not needed.

With Standard fields, there is no unique index and hence those permissions are required.

  • I don't think it matters which unique index mode you use, but you definitely do need the unique index.
    – sfdcfox
    Feb 9, 2021 at 17:20
  • Yes, you are correct! It needs to be unique is what I want to convey and standard fields are not unique. Feb 9, 2021 at 17:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .