0

Here's my SOAP Envelope:

<?xml version="1.0" encoding="UTF-8"?>
    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <soapenv:Header>
    <fueloauth>access token here</fueloauth>
  </soapenv:Header>
   <soapenv:Body>
    <CreateRequest xmlns="http://exacttarget.com/wsdl/partnerAPI">
        <Options/>
        <Objects xsi:type="Email">
            <Name>Authorization Email</Name>
            <Description>Authorization email sent when someone logs into a secure CloudPage.</Description>
            <HTMLBody><![CDATA[<html> <head> <body> Your unique link is: <a href="%%UniqueLink%%">%%UniqueLink%%</a> </body> </head></html><custom name="opencounter" type="tracking"> <table cellpadding="2" cellspacing="0" width="600" ID="Table5" Border=0><tr><td><font face="verdana" size="1" color="#444444">This email was sent by: <b>%%Member_Busname%%</b><br>%%Member_Addr%% %%Member_City%%, %%Member_State%%, %%Member_PostalCode%%, %%Member_Country%%<br><br></font></td></tr></table>]]></HTMLBody>
            <Subject>Your unique Dashboard Metrics Landing Page access link</Subject>
            <EmailType>HTML</EmailType>
            <IsHTMLPaste>true</IsHTMLPaste>
        </Objects>
    </CreateRequest>
</soapenv:Body>
</soapenv:Envelope>

When I execute this, here's my response:

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope
    xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing"
    xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd"
    xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
    <soap:Header>
        <wsa:Action>CreateResponse</wsa:Action>
        <wsa:MessageID>urn:uuid:1e2d05dc-8fa7-4dcf-b45c-95e9d368e2a0</wsa:MessageID>
        <wsa:RelatesTo>urn:uuid:1e7e0383-694b-4ccb-8693-523e825a99d9</wsa:RelatesTo>
        <wsa:To>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:To>
        <wsse:Security>
            <wsu:Timestamp wsu:Id="Timestamp-62d19310-ef33-419f-b2ca-481430dac37d">
                <wsu:Created>2021-01-29T22:09:52Z</wsu:Created>
                <wsu:Expires>2021-01-29T22:14:52Z</wsu:Expires>
            </wsu:Timestamp>
        </wsse:Security>
    </soap:Header>
    <soap:Body>
        <CreateResponse
            xmlns="http://exacttarget.com/wsdl/partnerAPI">
            <Results>
                <StatusCode>OK</StatusCode>
                <StatusMessage>Created Email.</StatusMessage>
                <OrdinalID>0</OrdinalID>
                <NewID>30950</NewID>
                <Object xsi:type="Email">
                    <PartnerKey xsi:nil="true" />
                    <ObjectID xsi:nil="true" />
                    <Name>Authorization Email</Name>
                    <HTMLBody>&lt;html&gt; &lt;head&gt; &lt;body&gt; Your unique link is: &lt;a href="%%UniqueLink%%"&gt;%%UniqueLink%%&lt;/a&gt; &lt;/body&gt; &lt;/head&gt;&lt;/html&gt;&lt;custom name="opencounter" type="tracking"&gt; &lt;table cellpadding="2" cellspacing="0" width="600" ID="Table5" Border=0&gt;&lt;tr&gt;&lt;td&gt;&lt;font face="verdana" size="1" color="#444444"&gt;This email was sent by: &lt;b&gt;%%Member_Busname%%&lt;/b&gt;&lt;br&gt;%%Member_Addr%% %%Member_City%%, %%Member_State%%, %%Member_PostalCode%%, %%Member_Country%%&lt;br&gt;&lt;br&gt;&lt;/font&gt;&lt;/td&gt;&lt;/tr&gt;&lt;/table&gt;</HTMLBody>
                    <Subject>Your unique Dashboard Metrics Landing Page access link</Subject>
                    <IsHTMLPaste>true</IsHTMLPaste>
                    <EmailType>HTML</EmailType>
                </Object>
            </Results>
            <RequestID>6b344304-9eef-456c-9943-572c75d2e17d</RequestID>
            <OverallStatus>OK</OverallStatus>
        </CreateResponse>
    </soap:Body>
</soap:Envelope>

However, I don't see this email anywhere in Content Builder. I read some mixed content on whether SOAP API works with creating emails. Salesforce documentation indicates so, but I also read on other sites that for Content Builder, we have to use REST API. So, I'm not exactly sure what's going on here. Help! Where's my email?

1 Answer 1

4

SOAP API only creates in Classic Content, which means if your email was created it would be in the classic email section. (Which may no longer be possible since Classic is being sunset)

To create a new email you need to use the Content Builder REST API.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .