0

I am getting 0% code coverage error while trying to validate changesets in production using run specified tests. I tried 3 unrelated deployments and all of them gave the same error. The changesets are getting validated if I don't select the run specified tests option. I am providing each test class on a new line in the run specified tests option. The error says that all the test classes have 0% coverage. The classes do have coverage in sandbox.

As the deployments are unrelated, the problem does not seem to be in test classes. Also the changeset validates if I don't use run specified tests.

No new validation rules or process builders are added to production. I am not sure what the problem is. Please guide. Thank You!

3
  • Have you tried by using the commas instead of adding the each test class in separate line which should fix the issue.Ex:Test1,Test2,Test3,....etc Jan 30 at 7:50
  • @ShirishaPathuri Thank You for the response! No, I have not tried that. I always do deployments by pasting test classes on a new line so there is no reason it should not work this time. Anyways, I'll try it.
    – Koustubh
    Feb 1 at 7:54
  • @ShirishaPathuri You were right! That was the problem. Thank You! I am not sure why I never got this problem before.
    – Koustubh
    Feb 1 at 16:18
1

Yes,test classes separated by commas should work.You can see the information on using Comma in this for multiple test classes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.