7

I have a PushTopic created, and have a VF page with some js in it that subscribes to the topic and logs any results to the console. I've verified that I'm getting results if I'm logged in as a standard user viewing the VF page. However, if I'm logged in as a customer community user, I see no results -- I also see no errors, which is frustrating.

I'm fairly certain the issue is the customer community profile does not have access to the PushTopic object. I haven't been able to find anything in the docs, though, that says that only standard users can be granted permissions on that object.

Is there something that I'm missing? Perhaps there a trick to making PushTopics available to community users? Or does the streaming API truly only work for standard users?

  • Have you tried adding without sharing to the class that surfaces the PushTopic query? And are these Customer Community Login Users or just guests? – bigassforce Apr 21 '14 at 19:14
  • They are authenticated Customer Community users, not the guest site user. Unfortunately without sharing won't work because of the need to limit the topic results to records the authenticated user owns. – Tim Smith Apr 21 '14 at 20:03
  • So you have a PushTopic for each user...? Can you check this out and give feedback? salesforce.stackexchange.com/a/30223/320 – bigassforce Apr 21 '14 at 20:08
  • No just one topic, as the query respects sharing rules. There are other reasons that prevent us from losing the with sharing -- it is good to know about the supported expressions, though, so thanks! – Tim Smith Apr 21 '14 at 21:35
  • Did you ever find a solution to give access to customer community users? – Jorjani Jun 28 '16 at 15:38
7

You cannot give community users access to the Push Topic object. it is not available on profiles and if you try to assign it via permission sets, you get the error "Can't assign permission set StreamingAPI to user xxxxxxx. The user license doesn't allow the permission: Read Push Topics"

  • Is this for sure the case? i.e., There is no way to give access to customer community users? – Jorjani Jun 28 '16 at 15:36
  • I wasn't able to find any documentation or confirmation, just to see that it does not show on the Profile and throws that error when assigning a permission set. I did try talking to one of the engineers at the world tour and they didn't seem familiar with the limitation. You can always try reaching out to your account exec and ask them if this is something they could enable for you. – brezotom Jun 28 '16 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.