2

we have that Custom Metadata which contains a "Entity Definition" field, which is basically a lookup to an object (either standard or custom).

We pulled our source from a sandbox to a Github repo, as we want to move to a more modern development workflow, and make use of sfdx and scratch orgs. For now, our metadata is not in any sort of package ; the source is in sfdx format (or as Salesforce call it, the "new" format), but that's it.

The issue

when we deploy the custom metadata records, we end up having the following : Custom metadata list

The name of the object in the entity definition field does not appear. The code using the custom metadata works properly though. As you can see, it fails to display the object name on custom objects only, but works on standard ones.

When you click Edit on one of them, the object is properly selected in the picklist : Custom metadata edition

When you try to create a new record for that custom metadata, same issue : you select the object, and Salesforce fails to display the name in the list view.

So to me it is not related to the "data" we push to the scratch org, but more an issue with the org itself.

Has any of you encountered that issue ?

Thank you

Edit : added "Hi", don't know why but it did not made it to the final post

1
  • sounds like a bug that you should open a case with salesforce support! Jan 28 '21 at 15:58
0

Well it turns out that the metadata was exported from an org in a specific language (French, always has been). So the objects have been created in that language.

When creating the scratch org, the user has been switched to English for the convenience of the Salesforce partner who worked on it with us.

No English translation existed for those objects hence the {0}.

Switching back to French solved the issue.

Sounds like a bug to me, as it could at least display the name in the only known translation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.