I wanted to put in my Companys website on the right side of the SF Login Page instead of the advertisement. When I put In the Link of my company it doesn't work, but when I tried it with "sown.io" it worked. My website uses https:// & ssl encryption. It looks like that the reason is the iframe.

is there a way to do this with the force.com pages?

  • Did you check the browser console? Do you find any errors? Make sure the link supports cross domain. Please share the Browser console errors if you see any. Jan 26, 2021 at 13:57
  • If I add a force.com (Site) then I geht the error: Refused to display 'Domain.salesforce.com/…' in a frame because it set 'X-Frame-Options' to 'deny'.
    – peXeq
    Jan 26, 2021 at 14:44
  • Please check the Clickjack Protection Level of the Site. 1. Go to Sites under Setup. 2. Under Sites section, click the Site Label to open the Site. 3. Set Clickjack Protection Level to "Allow framing by any page (No protection)". It takes at least few mins. So, test it after 5 mins to view the changes in Incognito Mode. Jan 26, 2021 at 17:55
  • The Clickjack Protection Level is already "Allow farming by any page (No protection).
    – peXeq
    Jan 27, 2021 at 7:30

1 Answer 1


It was my fault, I used a wrong url from the site. If you create a page for the right frame, select a name in sites for the page. Then take a look into the preview as user and copy the link and put this link into the my domain setting for the right frame.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .