When installing the Salesforce CLI with the Spring '21 pre-release Salesforce DX plugin, I'm getting an incompatible node version error.

This command:

sfdx plugins:install salesforcedx@pre-release

Results in this error:

The engine “node” is incompatible with this module. Expected version “>=14". Got “12.18.3”

  • We've started getting similar error on our pipelines since today, but we are using stable version: sfdx-cli/7.85.0 with node 10. After trying to install sfpowerkit plugin, we've got an error message: [ "The engine "node" is incompatible with this module. Expected version ">=12.0.0". Got "10.17.0" ] Everything was fine just yesterday. Seems like issue is a bit broader than just in scope of pre-release version.
    – wesaw
    Commented Jan 18, 2021 at 17:49

1 Answer 1


This error shows up even if you have the right node version installed in your environment. The reason why this happens is that the default Salesforce CLI installation ships with a node server bundled with it.

As of today (2020-01-18), the internal node version shipped with the CLI is 12.18.3 and the issue is that the pre-release Salesforce DX plugin expects node v14 or higher.


  • wait for an update of the core CLI which will update the built-in node server (waiting for an ETA on this but it should be pretty soon).
  • install a v14 node server yourself and install the Salesforce CLI as a node package.
  • 1
    "No software" ;)
    – altius_rup
    Commented Jan 19, 2021 at 16:34
  • 1
    Joke aside, I believe that the "no software" tagline applies to users, not developers.
    – POZ
    Commented Jan 21, 2021 at 7:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .