How do I delete non-indexed custom fields on a Big Object ? I do not see a 'delete' option next to 'edit' option of a field.

1 Answer 1


I think you cant delete a field or indexes in Big Object once created, you need to start over with a new Big Object.

I can see a documentation for indexes for this :


After you’ve created the index, you can’t edit or delete it. To change the index, you must start over with a new big object.

But not for fields, but I think that will apply to fields too.

  • Ok. I think so too. First I thought it might be a profile permission issue. But looks like a delete option is not there Commented Jan 12, 2021 at 7:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .