1

I've added a custom field to the Activities object which I'm trying to migrate data into using the Data Loader on the Event sub-object. However, when I'm creating the map for loading, I do not see my custom field as an option. I've tried restarting the Data Loader but that doesn't help. Any ideas on how I can fix this?

2
  • 2
    did you set the custom field to be accessible for the logged in user in data loader?
    – Bforce
    Commented Apr 17, 2014 at 16:21
  • The user for Data Loader is the root admin, and should have access to the field. I'm not sure where I can view the access permissions for the field, but if you're referring to field-level security, then no, the read-only checkbox is unchecked for the sysadmin.
    – Dezzie
    Commented Apr 17, 2014 at 16:24

1 Answer 1

2

Please check the field level security of the particular field. make it visible for your profile and then try accessing it via API.

2
  • Thanks, that fixed it. What I don't understand is why I didn't have to set the field-level accessibility to Visible for my profile for other custom fields in other objects such as Accounts, Contacts, etc. I was able to migrate the data over using this profile even though the field was not visible to it.
    – Dezzie
    Commented Apr 17, 2014 at 16:26
  • My guess is that You must not have forgotten to make the custom fields visible for your particular profile when you were creating them. Commented Apr 17, 2014 at 20:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .