4

I have set up Salesforce as IDp as well as SP. I am able to login to Service Provider org by navigating to URL of IDp "https://MyDomain.salesforce.com/idp/login?app=0sp40000000T3fU" from Browser.

However, When I try to attempt same from Salesforce1, I am geeting error like

The value of the "app" parameter contains a character that is not allowed or the value exceeds the maximum allowed length.

I already searched everything and found that it has something to do with "RelayState", Not sure how to configure it.

Please suggest some pointers.

2

I am not sure how to resolve above problem, However I got hint from this article "https://developer.salesforce.com/page/Single_Sign-On_for_Desktop_and_Mobile_Applications_using_SAML_and_OAuth" to try for SP initiated SSO.

So, In MyDOmain setting page of ServiceProvider, I disables standard login page of salesforce and enable SSO settings created previously.

In Salesforce1, I set up URL of Service Provider and it worked. I have documented this in one of my blog post.

Please share your thoughts on same issue so that it would help me and others to understand it better.

Jitendra Zaa

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.