0

Below is the config file for the sfdx project

{
  "orgName": "Test company",
  "edition": "Developer",
  "features": ["MultiCurrency"],
  "settings": {
    "enhancedNotesSettings": {
      "enableEnhancedNotes": true
    },
    "lightningExperienceSettings": {
        "enableS1DesktopEnabled": true
    },
    "securitySettings": {
        "passwordPolicies": {
            "enableSetPasswordInApi": true
        }
    },
    "mobileSettings": {
        "enableS1EncryptedStoragePref2": false
    },
    "quoteSettings": {
      "enableQuote": true
    }
  }
}

But when I try to create a unlocked package/push the source to scratch org I get the below errors ERROR running force:package:version:create: Account: Error parsing file: Element {}enableRelateContactsToMultipleAccounts invalid at this location in type AccountSettings -- package error

Error shape/settings/Account.settings Account Error parsing file: Element {}enableRelateContactsToMultipleAccounts invalid at this location in type AccountSettlid at this location in type AccountSettings -- scratch org push error.

can anyone help me understand am I missing anything.

Thanks!

1
  • Are you completely updated with the latest version of sfdx? When creating orgs recently there has been a message about this setting. Dec 19, 2020 at 2:28

1 Answer 1

0

How does your source code look? I am not fully sure about that error, but it looks like you are trying to push source which depends on the enableRelateContactsToMultipleAccounts setting, which previously have been enabled (but now is disabled in new created scratch orgs).

I would suggest either adding "ContactsToMultipleAccounts" to your features for the scratch org (reference), or try adding the enableRelateContactsToMultipleAccounts flag to the settings part. This should enable this setting when you create a new scratch org.

For a first test to see if this is the issue, try to manually enable "Relate contacts to multiple accounts" by going into Setup -> Account Settings and checking the checkbox there. After the setting is enabled, try pushing the source again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.