I am trying to create a custom Formula field on the OrderProduct standard object that is new with the Spring 14 release. However, while the standard fields ListPrice & UnitPrice are available in the merge field drop down on the formula editor, the standard TotalPrice field is not. From what I can tell, the field level security for TotalPrice is the same as that of the ListPrice field yet ListPrice is available in the drop down.

All three fields are Currency fields and the Formula field I am trying to create returns a Currency value.

  • 1
    For what it is worth, since I couldn't figure it out for you, I tried to reach out to the #askforce community as well - twitter.com/jessealtman/status/456460973776203776 Commented Apr 16, 2014 at 15:56
  • Thanks Jesse. I did submit a case just to have salesforce take a look at this. Commented Apr 16, 2014 at 17:38
  • 1
    I did get a response from Salesforce regarding the case that I entered. They did some research and referred me back to this Stack exchange post in the hopes that it would help. LOL. Commented Apr 17, 2014 at 12:00
  • Hahaha! That is hilarious Sean! Well, did you help yourself or what? Commented Apr 17, 2014 at 12:11
  • All comments here helped in deciding to use the workaround of UnitPrice * Quantity but the question still remains why TotalPrice cannot be used. Commented Apr 17, 2014 at 15:43

4 Answers 4


I took a look and couldn't see it either. I did a bit of research in the Spring '14 release notes and nothing there referenced why a field like that wouldn't be available. TotalPrice appears to be a formula itself, combining Quantity x UnitPrice. Interestingly enough, there appears to be two sets of documentation available for OrderItem as well (http://www.salesforce.com/us/developer/docs/api/Content/sforce_api_objects_orderitem.htm & http://www.salesforce.com/us/developer/docs/officetoolkit/Content/sforce_api_objects_orderitem.htm), neither of which have TotalPrice listed as a field. EDIT: Peter Knolle did find it in Salesforce Help

At this point, my guess is that this is some sort of bug. I looked at their open/known issues related to order and didn't see anything. My suggestion would be to open up a case and see what Salesforce says. There may be something weird about TotalPrice that isn't obvious that is preventing it from being listed. Unfortunately, there isn't a ton of documentation surrounding it just yet.

  • 1
    I see it defined in the Salesforce Help for Order Product. Commented Apr 16, 2014 at 17:17
  • 1
    Good find @PeterKnolle. According to the description, TotalPrice kind of works as I guessed: Quantity of the order product multiplied by the unit price. Commented Apr 16, 2014 at 17:23

Salesforce has gotten back to me regarding this issue. They are reporting this as a known issue. The details of this issue are below and the link to the issuse is: https://success.salesforce.com/issues_view?id=a1p30000000T3UnAAK

Field Updates on Custom Currency Fields using OpportunityProducts.TotalPrice in Formula not Triggered as Expected


Last updated 28 days ago ·Reference W-1060096 ·Reported By 0 users

When multiple workflow Field Updates exist on the Opportunity Products object that reference the "Total Price" field, some updates may be skipped.

1. Create a custom Currency field on Opportunity Products. 
2. Create a workflow Field Update that updates the custom field to a constant value, such as 55. 
3. Create a second Field Update that updates the custom field using a formula that returns the value of OpportunityProduct.TotalPrice.

The current workaround is to replace the reference to the "TotalPrice" field with its calculation: "UnitPrice * Quantity".

Just received confirmation from Salesforce that:

The "TotalPrice" field is calculated dynamically via the UI and only exists when the UI displays the product records. Hence it can't be used in formula fields or other areas (like workflow). This calculation is not exposed at the API or Apex level. The "TotalPrice" is the units*price so that should be used in place of "TotalPrice".


I guess to answer your question: Instead of making a formula field that references TotalPrice, just make it reference Quantity * UnitPrice.

  • 1
    That does appear to be the workaround at this time. Commented Apr 16, 2014 at 18:20
  • Great! If that helps, please mark the question as answered. Commented Apr 16, 2014 at 18:21
  • That's a good workaround! It still doesn't exactly explain why it wouldn't be available for use in a formula. I found this knowledgebase article, but it still seems like it should be available in a formula as formulas are evaluated on reads. Commented Apr 16, 2014 at 18:43
  • The above formula work-around also works for me in all situations. I'm not sure what the thinking was behind hiding such a standard field, would be curious. Commented Jan 12, 2017 at 11:48

I've been working with the new Order and Order Product (or OrderItem) objects, and I've noticed some inconsistencies.

My process was to use Workbench (workbench.developerforce.com/login.php) to explore the fields that actually reside on these objects (particularly OrderItem), because the fields that show in the 'customize object' subsection of Setup don't appear to be totally accurate.

I got several errors referencing fields that were appearing in the 'fields' listing from Apex. I'm not sure what's happening on SFDC's side, but it looks like Workbench has the most up-to-date field listing.


For whatever reason, several Order and OrderItem fields default to 'not visible' so they won't appear on Workbench when they're on the fields listing. The fields need to be individually whitelisted at the profile level (why?!).


  • Thanks David, I did use Workbench to confirm that the TotalPrice field was not listed on the OrderItem object. Commented Apr 16, 2014 at 17:43
  • I can't access the OrderItem TotalPrice field in Apex and don't see it in Workbench. I do see it on the field listing on the Object definition page, and it is on the page layout, and I can see it on the detail page of a record. Just opened a support case 10522931. Commented May 7, 2014 at 15:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .