5

I have Screen flow Unlock Record Unlock Record

And want to set access for it to permission set

But in flow access window there are no flows. flow access

Could you please help me figure out why so?

2
  • Check flow security (help.salesforce.com/…)
    – Vinay
    Dec 10, 2020 at 21:34
  • @Vinay, thanks, but I haven't found any information there anything that clears my mind. Am I missing something? Dec 11, 2020 at 11:59

3 Answers 3

6
  • "Run Flow" permission lets you run all flows by default
  • On the list of Flows, click "Edit Access" on the right-hand end picklist. This will let you Override the default for one Flow at a time; the selected profiles (you can't do this for Permission Sets here) will see the Flow listed in their Enabled Flows list.
  • The result is that if you override the default behaviour, that flow won't be accessible to any user with a profile that isn't on the list, even though they have Run Flow permission.
  • You can then add the flow(s) where you have overridden the access, and add them to Permission Sets, one permission set at a time
3
  • 1
    This is a better answer than the accepted answer. Please accept the better one Dmitriy Bereza. Dec 20, 2022 at 13:59
  • @haryadoon, do you know the permission that lets one see the "Edit Access" option? It does not appear for my user/profile. Feb 27, 2023 at 21:05
  • Manage Flows...
    – haryadoon
    Feb 28, 2023 at 23:58
1

The System Permissions -> Run Flow inside the permission set should be active, to see the flow

1
  • You can't grant Run Flow to a set guest user. If the permission set is assigned to a set guest user, it will not let you set that permission. If you have a permission set with that option set and try to assign it to a site guest user, it won't let you. I think the issue may be that the documentation is a tad fuzzy. It says access must be granted to "flows" but I think they must really mean "screen flows." It doesn't look like there is individual access per flow for non-screen flows.
    – Ken
    Apr 25 at 17:17
1

Embellishing @haryadoon helpful answer with images.

On your list of flow click the dropdown and select EDIT ACCESS.

Dropdown Edit Access

Then select the Override default behavior checkbox.

Checkbox for Override

Finally:

  1. Go to the Guest User Profile (navigate there from your Digital Experience)
  2. Go to Flow Access
  3. Add available flows to enabled

Move Flow to enabled

5
  • I'm trying to flow this solution but the dropdown arrow shown above with the Edit Access option does not appear. Anyone know how to get that on the list view?
    – Ken
    Apr 22 at 13:40
  • Switching views, I found the dropdown however only "View Detail and Versions" and "Edit Details" are available. "Edit Access" is not available.
    – Ken
    Apr 22 at 13:47
  • Ken You need the "Manage Flow" permission. Go to your profile settings. Mine is System Administrator and the permission needed is checked by default and I can't edit it. If you are not a System Administrator go to your Profile and change it. Go to Setup>Profiles>'Your Profile'>App Permissions>Flow and Flow Orchestration> and check Manage Flows. You can also do this with a Permission set. Apr 24 at 15:17
  • I'm a Sys Admin and have Manage Flow. I think the issue is that feature may only exist for Screen Flows. There's some places in the documentation that simply say "flows" without specifying "screen flows" and that is creating confusion.
    – Ken
    Apr 24 at 20:14
  • Ken, thanks for sharing your findings about the 'screen flows' only having Edit Access. It made me go back and look at why some of my Autolaunched flows did have the Edit Access option. I discovered that the flows I built before 2020 with Cloud Flow Designer did have the option to Edit Access. Any new Autolaunched flow does not. Apr 26 at 16:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .