1

so for background. We are working for client with SFDX and packaged. We have build 3 packages trough last 2 years. Everything worked fine until today. We have huge development for last 4 months and finally got to the point of building new version fixing bugs and production deployment. So to do that one need to promote package version. While trying to do that with commend:

sfdx force:package:version:create -x -p xxxxxxxxxx -codecoverage

I dried to promote version but i requested code coverage check. So I did the commend and error:

ERROR running force:package:version:create: No such column 'SourceOrg' on sobject of type Package2VersionCreateRequest

Try this: Your Dev Hub does not have permission to specify a source org for your build org. Verify that you are authenticated to the correct Dev Hub and try again. Otherwise, contact Salesforce Customer Support for assistance.

I can create scratch org, new version of package, install versions on sandboxes. The package has 0 code in it. Would be grateful for any help.

1 Answer 1

1

It seems you have enabled Org Shape feature. As per documentation,

The ID of the org whose shape (features, settings, limits, and licenses) information is used for creating scratch orgs used to validate metadata during creation of a second-generation managed package or unlocked package. This field is available in API version 50.0 and later.

We are having --codecoverage flag enabled it's working smooth. I think only difference here would be the Org Shape feature(since we don't have that enabled in our Dev Hub).

1
  • Yep the problem was Salesforce haven't implemented error messages yet and instead of just state that there is no command -codecoverage use --codecoverage it has thrown error. :D Salesforce developer support looked for that 2 days so i feel not so stupid right now xD Dec 17, 2020 at 11:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .