0

We have a legacy system connecting to us. Before saving the actual tender details they check the connection with Salesforce. They are getting error shown in response below. And on UI it shows that your salesforce session has expired. What could be the reason behind this response? I also tried to do a select query still received the same response.

Request:

 <?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns="urn:enterprise.soap.sforce.com" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <soapenv:Header>
        <SessionHeader soapenv:mustUnderstand="0">
            <sessionId xsi:type="xsd:string">xxxx</sessionId>
        </SessionHeader>
    </soapenv:Header>
    <soapenv:Body>
        <getServerTimestamp></getServerTimestamp>
    </soapenv:Body>
</soapenv:Envelope>

Response:

HTTP/1.1 307 Temporary Redirect
Date: Wed, 09 Dec 2020 08:53:59 GMT
X-B3-TraceId: xx
X-B3-SpanId: xx
X-B3-Sampled: 0
Cache-Control: no-cache,must-revalidate,max-age=0,no-store,private
Set-Cookie: BrowserId=xx; domain=.salesforce.com; path=/; expires=Thu, 09-Dec-2021 08:53:59 GMT; Max-Age=31536000
Expires: Thu, 01 Jan 1970 00:00:00 GMT
Location: https://test--qa.my.salesforce.com/services/Soap/c/15.0/00S1w000000sb6D
Transfer-Encoding: chunked

The URL has moved <a href="https://test--qa.my.salesforce.com/services/Soap/c/15.0/00S1w000000sb6D">here</a>
1
  • What URL is the SOAP request being sent to? This response suggests they're using the wrong URL. – sfdcfox Dec 9 '20 at 14:21
0

The new Critical Update for stabilizing host names in Sandboxes is probably in play here. You will need to update your client to use the correct endpoint. This usually happens because the integration is coded to "calculate" the server URL instead of using the URL the server tells the integration to use. This should be fixed in the client.

Further, API versions 20.0 and below will be removed in Summer 21, so you should plan on updating this integration before then. Also, don't just "kick the can down the street" to version 21.0, as versions 30.0 and lower will be deprecated the following year. Now is the time to fix and update your integration before it no longer functions at all.

1
  • Thanks a lot! This helped. It is working fine after removing instance. – surabhi panwar Dec 9 '20 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.