0

I am not able to use salesforce developer console, I have admin privilege in my org.

When I try to use the developer console using any browser I am getting below frozen screen.

I tried reopening, but nothing is working.

Developer console

11
  • Tried incognito also but not working.
    – ABHIN B.T
    Dec 9, 2020 at 8:56
  • How long do you wait, and have you tried looking at the browser's inspector to see what's going on?
    – Phil W
    Dec 9, 2020 at 9:05
  • I tired waiting for up to 20 mins.
    – ABHIN B.T
    Dec 9, 2020 at 9:11
  • Uncaught TypeError: b is not a function at h.loadContent (ApexIDEPanels_Ext4.js:344) at h.<anonymous> (ApexIDEPanels_Ext4.js:185) at h.fire (ext-all.js:18) at h.continueFireEvent (ext-all.js:18) at h.fireEvent (ext-all.js:18) at h.fireEvent (ext-all.js:18) at h.f (ApexIDEPanels_Ext4.js:188) at h.fire (ext-all.js:18) at h.continueFireEvent (ext-all.js:18) at h.fireEvent (ext-all.js:18)
    – ABHIN B.T
    Dec 9, 2020 at 9:12
  • 1
    @PhilW There's a fix in Help, actually.
    – sfdcfox
    Dec 9, 2020 at 10:14

1 Answer 1

3

You don't need to contact support. You can fix this yourself.

This is noted in the Help topic "Developer Console menus are unresponsive'

  1. Login to Workbench and go to REST Explorer
  1. Use the following query in Workbench to get the IDEWorkspace

/services/data/v31.0/tooling/query/?q=SELECT id, name from IDEWorkspace

ID of IDEWorkspace is "1dexxxxxxxxxxxxxx".

  1. Do GET operation for the found id with following query "/services/data/v29.0/tooling/sobjects/IDEWorkspace/1de1a0000014sEWAAY"
  1. You will see the content of IDEWorkspace
  1. Do DELETE operation on found record.
  1. Re-open Developer Console.
  1. Developer Console will work fine. As we created a new workspace and the old workspace has been deleted.And the slowness will also be removed.
1
  • Thank you so much @sfdcfox, It worked.
    – ABHIN B.T
    Dec 9, 2020 at 12:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .