I'm having some issues updating or deleting an SFDX package. When I run the following command sfdx force:package:update -p 0Ho... -d "OLD - Do not use. Will be deleted" -n "OLD Package" or sfdx force:package:delete -p 0Ho... I get the following error: "ERROR running force:package:update: invalid server id" or "ERROR running force:package:delete: invalid server id"

Has anyone run into this issue before? I tried making sure my cli was up to date, checking permissions on the Dev Hub org and re-authing to the Dev Hub, but no luck.

  • I know its not ideal but try uninstalling sfdx and doing a fresh install and see if that helps. Dec 19, 2020 at 2:58

1 Answer 1


I have a similar issue and so did a little digging using queries against tooling API.

The packages I couldn't update or delete were listed in the tooling API

SELECT Id, Name, SubscriberPackageID FROM Package2

enter image description here

The SubscriberPackageID is supposed to refer to the Id of the MetadataPackage record in your org. It was here that I could find no entry for the packages.

SELECT Id, Name, PackageCategory FROM MetadataPackage

enter image description here

I have raised a case with Salesforce. One consideration is that We have had an instance move since those packages were created and seem to be no longer accessible.


After raising a Case, have had the following back from Salesforce

I got an update on the case from the senior Tier-3 team that it has been identified as a bug. The team is working on the fix and will try to deploy the fix as soon as possible. Though there is no ETA for the same but might be deployed as a patch in an upcoming release. We can also provide you the bug id i.e, W-8864667 for future reference on the fix of this issue.

see Known Issue - https://trailblazer.salesforce.com/issues_view?id=a1p4V0000003yQoQAI

  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review
    – identigral
    Jan 14, 2021 at 16:52
  • @identigral The answer stipulates that the entry is missing from the org MetadataPackage table and to get an entry into that table or to otherwise resolve then you need to raise a case with Salesforce.
    – richsabel
    Jan 14, 2021 at 17:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .