0

If I have a DE and is properly linked using SubscriberKey, when try to send a test, it says success but is not sent.

So there's no way to create a test if I have not added manually this email as an opted in Subscriber, corrrect?

That's what I understood : https://help.salesforce.com/articleView?id=mc_es_send_preview.htm&type=5

I would like to this test email is being added automatically to the "All Subscribers" but seems that's not possible. Only when is a real sent then is added.

1

I would suggest you to see if email address field data type in the sendable DE is actually email. Also, try to see if you are using word TEST in your email subject line or a preheader.

All of this possible scenarios happened to me at some point of time.

2

Even if you do test send to an email address that was not present on your All Subscribers list earlier, you should receive the email and the record will get added to the All Subscribers list. (I did a small test send with a new email address just to be sure)

In case the subscriber is unsubscribed, the test send will not happen. Also, in case the subscriber has a status of bounced in All Subscribers list, email will not be sent.

1
  • 1
    Correct. Test sends are done "impersonating" another user and should behave like that user with regards to unsubscribed / held status, as well as auto-suppressions, list detective etc. New users will get added to all subscribers lits. – Jonas Lamberty Nov 26 '20 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.