0

I am trying to implement Twilio Flex for Salesforce Open CTI. I am using a twilio trial account. I have enabled Inbound calls to salesforce using twilio flex. Now I am trying to implement Click-To-Dial for salesforce outbound call using twilio flex. But I am stuck in making an Outbound call. When I click a phone number from the salesforce contact page, the twilio window pops up and shows a message 'Attempting Outbound call now' then stops and no call is placed in the specified number.

A task is creating with this comment -

[Attempting] outbound voice. Details: PostData:
CallTo: -
CallFrom: NO_CALLER_ID
WorkflowSid: WW5fbcbf6ee9d199b13252baf6939ba3cc
TaskChannelSid: TC4a4c6f7cb0a3fb09a87cd27e0adfa8f8
WorkspaceSid: WSfcffdb601ba21fec6aa21389d11f5e85
WorkerContactUri: client:playwithpackage_2Dm1_40free_2Ddev_2Ecom
WorkerSid: WKce67db7d7e1e88aa4505542d493b69bf
WorkerName: [email protected]
Priority: 999
Direction: outbound
TaskChannelUniqueName: voice
Direction: outbound 

And every time I got this error when trying to make a outbound call

Refused to run the JavaScript URL because it violates the following Content Security Policy 
directive: "script-src 'self' 'nonce-fbd8b58ceca1755f12efd1a1e2bd2a8f' 
chrome-extension: 'unsafe-eval' *.canary.lwc.dev *.visualforce.com 
https://ssl.gstatic.com/accessibility/ https://static.lightning.force.com". 
Either the 'unsafe-inline' keyword, a hash ('sha256-...'), or a nonce 
('nonce-...') is required to enable inline execution.

Error: outbound calling disabled
    at assets.flex.twilio.com/releases/flex-ui/1.23.1/twilio-flex.min.js:1461
    at assets.flex.twilio.com/releases/flex-ui/1.23.1/twilio-flex.min.js:1461
    at Object.next (assets.flex.twilio.com/releases/flex-ui/1.23.1/twilio-flex.min.js:1461)
    at assets.flex.twilio.com/releases/flex-ui/1.23.1/twilio-flex.min.js:1461
    at new Promise (<anonymous>)
    at i (assets.flex.twilio.com/releases/flex-ui/1.23.1/twilio-flex.min.js:1461)
    at e.startOutboundCall (assets.flex.twilio.com/releases/flex-ui/1.23.1/twilio-flex.min.js:1461)
    at e.<anonymous> (assets.flex.twilio.com/releases/flex-ui/1.23.1/twilio-flex.min.js:142)
    at assets.flex.twilio.com/releases/flex-ui/1.23.1/twilio-flex.min.js:142
    at Object.next (assets.flex.twilio.com/releases/flex-ui/1.23.1/twilio-flex.min.js:142)
(anonymous) @ assets.flex.twilio.com/twilio/flex-salesforce-integration/1.4.0/plugin-flex-salesforce-integration.js:1

click to dial

flex pop up

Any guidance to implement the salesforce outbound call using Twilio Flex will be great.

5
  • Do you see any error in the browser console logs? Nov 24, 2020 at 10:49
  • Yes, I got a error every time. (updated in post) Nov 24, 2020 at 13:58
  • The error Refused to run the JavaScript URL because it violates the following Content Security Policy directive: "script-src 'self' 'nonce-fbd8b58ceca1755f12efd1a1e2bd2a8f' chrome-extension: 'unsafe-eval' *.canary.lwc.dev *.visualforce.com https://ssl.gstatic.com/accessibility/ https://static.lightning.force.com". Either the 'unsafe-inline' keyword, a hash ('sha256-...'), or a nonce ('nonce-...') is required to enable inline execution. Nov 24, 2020 at 15:21
  • As mentioned in trailblazers.salesforce.com/answers?id=9063A000000E3TuQAK , can you try making Twilio flex as default app for calling and let me know if it fixes the issue? Nov 24, 2020 at 15:56
  • The answer mentioned in https://trailblazers.salesforce.com/answers?id=9063A000000E3TuQAK is for Ringcentral. And I could not find any option to make Twilio flex as default app for calling. Besides in 'Assigned App' section of a Profile 'Twilio Flex' is not listed to make it default. Nov 25, 2020 at 9:19

1 Answer 1

1

Finally I am able to make outbound calls form salesforce by Click To Dial/Dial Pad using Twilio Flex. To solve the console error

Error: outbound calling disabled

and make the outbound call working, Firstly I had to Enable the Dial Pad in Twilio flex Setting in Twilio. Then I had to set the Caller Id and other information there. enter image description here

You can get more information here https://www.twilio.com/docs/flex/developer/dialpad/enable

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .