0

I have a cloud page with smartcapture. I am using this Cloudpage as entry criteria into a journey that creates a new record and updates an Object in SF. i am able to map all required fields to the Journey data (see below) except one field (NPS Rate) which is greyed out. (second screenshot)

enter image description here

enter image description here

why would this be? I have the receiving field in SF with data type 'number' and the same for the smartcapture target DE.

7
  • 1
    Do you have any number fields in your journey data? – EazyE Nov 23 '20 at 2:01
  • Yes this field is a number field. Should I change it to text? If yes, Does the Salesforce field also need to be text? – Rahul G Nov 23 '20 at 2:07
  • 1
    I believe a salesforce number field has to map to a decimal DE field – EazyE Nov 23 '20 at 2:13
  • I changed it to decimal & it works now however I am really struggling to pass a constant 0 from the Email to the Cloud page. I tried @nps = 0 @nps = '0' @nps = "0" – Rahul G Nov 23 '20 at 3:01
  • 1
    havent tried it, but maybe 0.0 works. – DonL Nov 23 '20 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.