2

In VSCode, there used to be a type ahead window with suggestions of SLDS classes when you start to create one. This menu no longer appears for me.

For example when I would type <span class="slds- a window with suggestions of slds classes would appear. I've included a screenshot below.

I am using the latest version (1.51) of VSCode on Windows 10. I tried updating SFDX, the Salesforce CLI extension, restarting the program and rebooting computer.

slds type-ahead

4
  • The intellisense feature if I remember stopped working automatically a while back, and now triggers with ctrl + space shortcut. :( – Raul Nov 11 '20 at 15:01
  • @Raul this brings up a menu, but it is only classes that have already been used in the file, not the complete list of classes available. – Philip Bolognini Nov 12 '20 at 20:39
  • @AvijitChakraborty I have the SLDS validator extension installed. It does not have any affect on whether this menu appears or not. – Philip Bolognini Nov 12 '20 at 20:39
0

In the settings.json there is a setting:

"editor.quickSuggestions"

At first I thought this solved the problem, but then I realized it was only showing suggestions for slds classes that were already present in the file.

0

The problem was the specific version of the SLDS Validator extension. I had to install an old version of it (1.0.0). Then the type-ahead menu came back.

The current version I was on was not working (1.4.0).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.