3

I'm trying to embed some VisualForce pages in the layout for a Custom object.

This works fine in Firefox, but not in Chrome. Instead, for each embedded page (there are three) I get the message:

Your browser privacy settings have prevented this page from showing some Visualforce content. To display this content you need to change your browser privacy settings to allow "Third Party" cookies from the domain obfuscated-domain--c.visualforce.com. Alternatively, if your browser is Internet Explorer, you can add obfuscated-domain--c.visualforce.com to your trusted sites list in the security options page.

  • All cookie types are enabled in Chrome.
  • Existing cookies have been cleared and I've logged in again.
  • I've added the main site and the visualforce.com site to the list of 'Sites that can always use cookies' in Chrome

But the issue continues.

Anyone else had this issue? What's the solution?

Thanks!

1

AFAIK this behavior is a result of Chrome changing the default cross-domain (SameSite) behavior of cookies in Chrome version 84+. To accommodate this change it is necessary to use HTTPS instead of HTTP

Please refer to the following knowledge article for more information:

Google Chrome Browser Release 84 Changes SameSite Cookie Behavior and Can Break Salesforce Integrations

Solution:

In session settings enable the following:

Require secure connections (HTTPS)

Require secure connections (HTTPS) for all third-party domains

1
  • 1
    Thanks - this fixed it. I'm just shocked that Salesforce considers 'visualforce.com' as a 'third party' domain and would load embedded VF pages using anything other than HTTPS!
    – cyberspy
    Nov 10 '20 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.