2

So I just converted one of my older repositories to SFDX and I noticed that custom metadata has the extension .md which pre-SFDX wasn't a problem because a -meta.xml was appended. Now basically the repository thinks it's Markdown, my search tool thinks it's Markdown, and - worst of all - my IDE (IntelliJ) thinks it's Markdown.

So I think for GitHub I can force it with some Linguist magic to handle it correctly - but what about all the other instances? Do you have a problem with this as well? Is this a problem in VS Code? How do other people solve this?

2
  • Remove the file type mapping and Illuminated Cloud will work correctly again. Assuming that is what you are using with IDEA.
    – Phil W
    Nov 8, 2020 at 21:16
  • But wouldn't that also disable all of my actual Markdown files as well? So README.md would also stop working, right?
    – Semmel
    Nov 9, 2020 at 0:13

2 Answers 2

0

When using Illuminated Cloud and viewing files in the project navigator, by default the IDE "hides" all meta.xml files. For custom meta data files this has the effect of hiding the "-meta.xml" part of the file name extension (whereas for Apex Classes this means it actually hides the equivalent .cls-meta.xml file for example).

If, when you check the "Show meta.xml Files" option, as shown below, you still see the file as ".md" instead of ".md-meta.xml" then Mohith is very likely right:

Illuminated Cloud's Show meta.xml Files option

On the other hand, if the file is shown with the extension ".md-meta.xml" then I would say this might be to do with setting up an explicit file type mapping. I have found in the past that Illuminated Cloud has automated mapping and adding your own can mess the IC editor up. That said, Markdown is a pre-canned file type mapping in IDEA so this may not be your problem.

0

I think this may be an issue with the force:mdapi:convert. If you can reproduce it with just a custom metadata folder to narrow it down please log an issue.

Otherwise looks like this is an issue with the illuminated cloud that you need to work with the vendor.

We use Custom Metadata Type records in one of the sample apps Easy Spaces. You can use -meta.xml in the custom metadata files as shown here and you should be fine retrieving and deploying it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .