1

I uploaded a batch of 10,000+ Accounts. Out of the Load file, let's say I have a record by the name Acme. Acme has apparently been successfully uploaded according to the Success Log (which also has Acme's new SF ID). I then extract all Accounts, and Acme is no longer there. Additionally, when I go to the web interface, a search for Acme returns 0 results.

The cherry on top is that the number of records present in the database is equal to the number of records present in my Load file, i.e, all my records were indeed uploaded.

The funnier thing is that if I look at the Success log and pick out a random SF ID, and do a search for it in the Extracted Accounts, it shows a completely different name for that SF ID. I first thought this was because I was opening it in Excel and since the CSV format might find commas elsewhere and mess up the order, but after having opened it in Notepad, the problem persists.

I'm about to restart the entire migration process but before I do, I wanted to know if anyone's encountered this before and if they have any tips on how I should handle this.

4
  • That's a strange one.. since you have the id can you directly go to the record by giving it in url
    – Prady
    Apr 10 '14 at 15:06
  • If I take the ID of Acme from the Success Log and put it in the URL, it takes me to the Account information of another account altogether.
    – Dezzie
    Apr 10 '14 at 15:10
  • This is very odd -- I would rerun with a smaller set of data and use the default batch sizes in Data Loader settings - then verify the results
    – cropredy
    Apr 10 '14 at 16:13
  • Crop, read my answer :)
    – Dezzie
    Apr 10 '14 at 16:15
0

This is happening because of the Bulk API being 'On' in Settings of the Data Loader. I switched it off and migrated the data again, and there were no missing records and no mismatch of the ID against the name. Just to make sure, I did recreate the scenario and once again turn on the Bulk API setting and migrate my data again, and the initial issue did recur where some records were missing and the IDs were not matching correctly.

Moral of the story: Do not use Bulk API unless you're deleting records and are too lazy to go to the Recycle Bin and click 'Empty My (Organization's) Recycle Bin'.

1
  • The bulk API works fine, but I might wonder if the Data Loader has a bug?
    – sfdcfox
    Apr 12 '14 at 2:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.