2

Today I am facing a very weird situation when I log in using Microsoft Edge Browser. Then I am unable to open any settings in Salesforce Lightning Experience. But it is working fine in another browser, can you please provide me the solutions to fix this isse=ue. I believe I need to fix some settings in the MS Edge browser.

Please find the Error steps below, thanks in advance.

Asking for Login again & again

2 Answers 2

4

Issue is due to the change in SameSite cookie behavior on the Edge Chromium browser.

Please try the below steps

  1. Go to edge://flags
  2. Choose "Disabled" from the drop-downs against SameSite by default cookies and Cookies without SameSite must be secure flags

And The fix for this browser issue is available in Winter ’21.

Kindly review more details here

Thanks,

-1

Salesforce is not going to support the non-Chromium of Microsoft's Edge browser starting on December 31, 2020, as per this article:

Salesforce supports the latest stable version of the Chromium and non-Chromium versions of Microsoft Edge for Salesforce Classic and Lightning Experience. Salesforce supports Microsoft Edge Chromium only on Windows.


Maybe you are using the non-Chromium version. Either way, when you open different pages on Salesforce and other services the browser usually sends the session cookies with the request so the server can maintain your session active. If you are being disconnected when you open a new tab, maybe it is a browser setting or bug that is not carrying the cookies.

I would strongly advise to change browsers. Move to Firefox, Google Chrome, Brave or any other Chromium-based browser (since it is the foundation for Chrome, and Salesforce fully supports it).

4
  • But my case is different, I am using Microsoft's Chromium Edge. I believe that should not be the case. Can you please guide me in another way?
    – Virendra
    Oct 15, 2020 at 13:13
  • Check if you can find a setting like "Always allow session cookies" or something like that. It should be checked. If that doesn't work: change browsers. Oct 15, 2020 at 13:16
  • definitely, I have other browsers but also need to fix this issue.
    – Virendra
    Oct 15, 2020 at 13:20
  • I checked the 'Allow Cookies' but nothing changed.
    – Virendra
    Oct 15, 2020 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.