1

I submitted my managed package for a security review few days ago. After submitting, I found out that I don't have to use an Apex class in the package. So, I tried to delete that class but couldn't because it was part of a managed package. So, I annotated that class with @deprecated. 2 days ago, I got the result and CRUD/FLS Enforcement issue is raised on this class. Now, the problem is, I cannot edit this class as it throws this error: A class with name was deprecated for this package or this name is already in use, also I cannot delete the class. I went to Salesforce Partner Community and raised a ticket and got the permission to delete the managed classes. But, still I cannot delete the class(I don't know why). So, my question is, if I submit the package for security review again, will it raise the same issue again or ignore the issue as the class is now deprecated?

2
  • You can just wipe out the deprecated class, I mean, just leave only class declaration like public class DeprecatedClass {}, then it will pass security review easily and you won't need to worry about it. Oct 7, 2020 at 7:02
  • @MariiaIllarionova thats what I tried to do. But, as i have mentioned in my question, I cannot edit the class. Oct 7, 2020 at 7:07

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.