3

I created a new custom object in sandbox environment, and i want to send a mail by using send an button in activities related list but it is not showing, log a call button is visiable to me, but send an email button is not visiable what i want to do any suggestions

Activity Image

when i do it showing like this but in quote record email button is not visiable

activity image2

  • edit page layout of custom object, in Activity History related list there is tool icon, click on that, you will get column selection section and button section, click on button section, there you see the "send an email" button, just check on that.. it may solve your problem – Bharat Apr 8 '14 at 12:38
  • @Bharat as per u r suggestion i do it but it is not showing in record, in pagelayout it is showing can you check my second image – Sathya Apr 8 '14 at 12:49
  • please look for my ans, this is hapening due to email setup – Bharat Apr 8 '14 at 13:16
8

If it is sanbox, change deliverability setting under "Email Administration" as follows:

Go to Setup | Email Administration | Deliverability.

Change Access level picklist to "All email".

Click save button.

You should now see 'send an email' button in activity history related list

| improve this answer | |
  • This does not hide / show the email button, but merely prevents sandboxes from sending outbound emails uninentionally. – James Loghry Apr 8 '14 at 13:15
2

Check that your permissions are set up correctly. In particular, there is a "Send Email" setting on the profile that needs to be checked.

| improve this answer | |
2

This button / action visibility within a Lightning Community is controlled via the Global Publisher layout. If the Email action is not present on the layout then it will not display on the Activity History related list. You can confirm this by going doing the following:

  1. Go to Setup > Global Actions > Publisher Layouts > Global Layout.
  2. Edit the Global Layout.
  3. Locate the Email Mobile & Lightning Action called "Email".
  4. Add this to the Layout.
  5. Save

Clear your browser cache and log back into the Community and access a record where the Send Email action was not present, it should now be restored.

| improve this answer | |
0

'Send an Email' button is available in layout configuration but does not appear on layout.

  • Email Deliverability - correct
  • All Profile permissions - correct

Found the following knowledge article: https://help.salesforce.com/articleView?id=000232945&language=en_US&type=1

The "Send Email" button will be visible only on the detail view of the object record in Lightning Experience but not in Salesforce Classic UI.

Do they disable sending of emails for Salesforce Aloha (Classic)?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.