1

We're getting this issue all of a sudden in on-going CICD pipelines(Gitlab). It was working fine till date and suddenly this error is coming with each build trigger

Error -

ERROR No subscriber package version found for package id '0Ho<ID>'

Command being executed -

sfdx force:package:version:create --package 0Ho<ID> -k <KEY> -f config/project-scratch-def.json --wait 30 --json --targetdevhubusername <DevHubAlias>

sfdx-project.json

{
  "packageDirectories": [
    {
      "path": "force-app",
      "package": "<package-name>",
      "default": true,
      "dependencies": [
        {
          "package": "<parent-unlocked-package>@0.3.0.2"
        }
      ]
    }
  ],
  "namespace": "",
  "sfdcLoginUrl": "https://login.salesforce.com",
  "sourceApiVersion": "49.0",
  "packageAliases": {
    "<package-Name>": "0Ho<ID>",
    "<parent-unlocked-package>@0.3.0.2": "04t<ID>"
  }
}
3
  • worth checking if the package exists by running the sfdx force:package:list --targetdevhubusername <DevHubAlias> and make sure the package exists still Sep 28, 2020 at 5:06
  • Yes, it is present there. Still getting the same issue.
    – Ysr Shk
    Sep 28, 2020 at 17:38
  • 1
    Got the issue, it was having some compile time issue, when we tried to push the code to source org we identified that. And now its working fine.
    – Ysr Shk
    Sep 29, 2020 at 5:03

0

You must log in to answer this question.