0

While testing some changes in a user's Profile and Permission sets, I get

Insufficient privileges error for this operation

when

  • user clicks Send Email from a Case Detail page or Case feed
  • composes email and/or selects template
  • clicks Send // error ensues here; doing this incognito had no effect

The usual reason for this - the Case's Contact is private (has no parent Account accessible to the user) was not relevant for this occurrence.

User had Send Email permission, access to the template folder. Other users worked fine with similar permissions

What could be causing this?

1

So, I can't explain why but the following appeared to be the issue (and solution)

  • I was testing by exploiting the administrator Login As feature within our Staging sandbox
  • Said user had never logged into the Staging sandbox normally
  • Staging sandbox used single signon required for the Profile in question (I don't think this is relevant but complicated my life testing)

Clue:

  • I created a new user in the Staging sandbox with same profile/perm set as the failing user.
  • Starting from mydomain--staging.my.salesforce.com domain, I logged in normally.
  • I went to the same Case as the failing user and successfully sent email; no error

So ...

  • I had the real user (which failed) log in via single signon, go to the Case and then send email. Worked fine.

Conclusion:

  • Administrator Login-as a user that has never logged in before to said sandbox and then trying to send email from a Case fails with insufficient privileges.
  • Works fine if such user has at least logged in once (prior to me doing an administrator login-as)

YMMV

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.