I am trying to delete freshly created package, but error code says delete is not a valid command.

enter image description here

But it's available in official document


Still not working even after installing pre-release plugin enter image description here

Link: https://developer.salesforce.com/docs/atlas.en-us.sfdx_cli_reference.meta/sfdx_cli_reference/cli_reference_force_package.htm#cli_reference_delete


1 Answer 1


You will need to use prerelease version of the Salesforce CLI

You can install using the command below

sfdx plugins:install salesforcedx@pre-release

The functionality will be available once winter 21 v50.0 is generally available!

Also this will only work with the DevHub in prerelease orgs for now.

  • 1
    +1 In addition, you will not be able to actually use the command against an org that is still on Summer '20.
    – sfdcfox
    Sep 20, 2020 at 16:58
  • Still not working even after installing pre-release plugin
    – Ragul
    Sep 20, 2020 at 17:05
  • @Ragul what version is your devhub org? Sep 20, 2020 at 17:22
  • @sfdcfox good points on devhub needs to be in winter21 as well else the delete ability is not provided by the api Sep 20, 2020 at 17:28
  • 1
    You need an org with v50.0 as Devhub else this won’t work Sep 20, 2020 at 17:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .