1

This error shows up while trying to upload a file from within a community flow as a registered user and to a custom object created by the registered user himself:

Error shown while trying to upload the file

I'm using the standard lightning flow-component to upload files and this actually works if I use the Account object instead.

What I've tried so far based on my research on the issue:

  • Check that the sharing settings for the custom object are set to "Public Read/Write" for both internal and external users (I even changed the default access to "Private" and then back to "Public Read/Write").
  • Ensure that the field "Related Record ID" of the upload component contains a valid Id of the custom object (by displaying the used variable in the flow screen and compare it to the record Id).
  • Ensure that I can upload Files to the custom object within the "Notes & Attachments" related list.

Any help or guidance is appreciated - Thanks in advance.

EDIT

The variable I use in the "Related Record ID" parameter of the upload component is the same I used on the previous step to store the Id of the newly created custom object:

Storage of the new record id into the variable

Storage of the new record id into the variable

Assignment of the variable in the upload field

Assignment of the variable in the upload field

And as stated above, I double checked that the variable contains a valid Id and that the record exists (created by the regsitered user).

EDIT 2

These are the settings under Salesforce Files -> General Settings. Enabling the first or last option doesn't seem to have any effect and the other options do not seem relevant with regard to this issue.

enter image description here

  • What parameters are you passing to the standard component and how are they being populated? – Dave Humm Sep 18 at 14:54
  • @DaveHumm thanks for your answer - I edited the question with further information about the parameter used. – Eduardo López Sep 18 at 15:12
  • Is the file sharing enabled by library or by record? It should be in Setup > Files – manjit5190 Sep 19 at 15:39
  • Thanks @manjit5190 - I updated the question with a screenshot showing the general file settings. I guess you mean the last option? If so, I tried to enable it but as far as I can see, it does nothing in my case. The other options seem irrelevant and I did not find any other setting in the "Salesforce Files" menu which could be causing this particular issue. – Eduardo López Sep 20 at 7:45
  • Ok, I got it working - the community user profile needs Edit permissions granted by a permission set. See below for a detailed answer. Thank you guys for your support. – Eduardo López Sep 20 at 8:46
1

The solution is to create a permission set for the community user profile with (at least) "Edit" access to the required object.

If working with custom objects, be aware of possible license limits. As of September 2020:

enter image description here enter image description here

As a final note, you might want to modify the flow's execution settings to use record-level or global access:

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.