2

I am setting up my LWC dev environment with vscode but for some reason the intellisense for LWC only works if I hit ctrl + space, instead of showing up as I type.

Here's what it look likes as I type:

autocomplete without shortcut

Here's what it looks like if I hit ctrl + space:

autocomplete with shortcut

Interestingly enough, this only happens in .html files. Autocompletion in .js files works fine.

I've already tried reinstalling the SF extension pack and reloading VS code multiple times.

Help?

Thanks in advance!

5
  • Just to cover bases, is the JavaScript > Suggest setting in VSCode set to "Enabled"?
    – nbrown
    Sep 18, 2020 at 18:00
  • @nbrown I have. I've tried on two different machines. I'm starting to think this is the way the extensions behave (which is not good IMO). Thanks!
    – adriancg
    Sep 18, 2020 at 18:44
  • 3
    Looks like that's just the way it works for now. Following link seems to have a response from SF regarding the same: github.com/forcedotcom/salesforcedx-vscode/issues/2455.
    – arut
    Sep 18, 2020 at 22:10
  • @arut ah, bummer. Submit as an answer and claim your bounty good sir. Thanks!
    – adriancg
    Sep 18, 2020 at 22:18
  • Other than pointing out the existing limitation, neither my comment solves the problem nor provide a workaround. So, its OK.
    – arut
    Sep 19, 2020 at 4:51

1 Answer 1

0

Did you create your component via the right click context menu in VS Code? It's possible that there's a missing configuration file either among the component files or in your local project. Try recreating the component through that method and make sure the files are saved locally.

VS Code LWC Create Menu

1
  • I did create it with the context menu. It's weird that it only breaks for html files. Thanks for replying!
    – adriancg
    Sep 16, 2020 at 19:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .