0

I am trying to integrate http://salesloft.com/ with my salesforce production instance via OAUTH. When I try to login to production using my valid credentials (I an system admin), salesloft see OAUTH_APP_BLOCKED. However, "Salesloft" does not appear in the list of app in Manage Connected Apps, so I am unable to unblock it.

When I try to connect to our full sandbox (refreshed on Aug 3 2020), it succeeds.

I spun up a brand new dev sandbox and tried to connect to it. I get the OAUTH_APP_BLOCKED failure. What has changed since Aug 3? I downloaded the audit log and searched in it for "connected" and "oauth" but did not find anything relevant.

I cannot for the life of me figure out what is blocking this, nor can Salesloft engineers. Salesforce.com Support says they are not allowed to help with third party software.

Any ideas about how to investigate or resolve this?

2
  • 1
    Not sure if you have checked out Connected Apps OAuth Usage setup page (as you have not mentioned this anywhere in your question). Blocking/ Unblocking connected apps needs to be done from Connected Apps OAuth Usage section and not Manage Connected Apps section.
    – arut
    Commented Sep 16, 2020 at 5:12
  • It does not appear in either Manage Connected Apps or Connected Apps Oauth Usage, so I cannot unblock it.
    – Bo Laurent
    Commented Sep 16, 2020 at 19:11

1 Answer 1

0

Just had this same problem with Chili Piper. After hours of trying to figure it out, we finally realized that any BLOCKED apps within OAuth Connected App Usage shows up at the VERY BOTTOM of the list of apps... so it's not in the alphabetical order you would expect. We randomly stumbled upon it; hopefully that's the same case for you!

1
  • Yes, this is the problem. Seems like a bug.
    – Bo Laurent
    Commented Dec 14, 2020 at 0:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .