1

Im facing a redirect issue in my MC email links.

Steps to reproduce:

  1. Creating a dynamic link with AMPscript

Example: SET @magentourl = CONCAT('https://www.example.*/cart-link/cart/restore?token=',@magentotoken)

Button click href="%%=RedirectTo(@magentourl)=%%"

  1. Using the parameter mananager

sfmc_sub2=%%subscriberkey%%​&utm_source=blabla&utm_medium=%%emailname%%​&utm_campaign=%%emailname_%%​&utm_term=term​&utm_id=%%_JobSubscriberBatchID%%

  1. I put the qs url in https://wheregoes.com/retracer.php

  2. output where goes.com:

302 Redirect What I want to see in browser and only see in wheregoes.com https://www.example.*/cart-link/cart/restore?token=blabla&sfmc_sub2=blabla&utm_source=MCnieuwsbrief&utm_medium=blabla&utm_campaign=blabla&utm_term=term&utm_id=blabla 🍪 302 Redirect

What I see in Browser: https://www.example.*/checkout/cart/?sfmc_sub2=blabla&utm_id=1

What should I do, to be able to use a dynamic build up link in combination with the parameter manager.

Note: Parameter manager works with a static link. I need to see the UTM paramater in GA in combination with a dynamic build up link in AMPscript.

Any suggestions?

Robin

  • In my experience, 98% of the time the reason the parameters are stripped is because the resolving page that's redirecting visitors is not set up to carry the parameters to the final page. The remaining 2% is because of an extra "?" or a bad character in the URL. Of note, URLs in the email that are wrapped for tracking, should look more like "click.example.com?qs=encryptedParameters". – Eduardo Arias Sep 15 at 16:56
  • Are you getting two "?"s in your query string? – Macca Sep 16 at 2:24
  • @EduardoArias click.example.*/?qs=blabla 302 Redirect example.*/cart-link/cart/restore?token=blabla&sfmc_sub2=blabla&utm_source=blabla&utm_medium=blabla&utm_campaign=blabla&utm_term=term&utm_id=9 🍪 302 Redirect example.*/checkout/cart/?sfmc_sub2=blabla&utm_id=9 🍪 I Dont see double "?" in the url. But I see a double redirect. This URL I can see in the browser: 302 Redirect example.*/checkout/cart/?sfmc_sub2=blabla&utm_id=9. How should I build a dynamic link with the UTM parameters from the parameter manager in AMPscript? The URL. Robin – RobSource Sep 16 at 7:21
  • 1
    @RobSource - your code looks good, the issue is with the landing page. Seeing that the parameters are still in place on the first page - means it's working, but when it gets redirected to the next, it resolves to page that loses the parameters - is something the webmaster of the website has to fix/address. You can point it to the final page (like changing the original URL in your email), however, if that is not an option, there's nothing you can do on the email side to resolve that. – Eduardo Arias Sep 16 at 17:17
  • 1
    @macca Thank you for the response. The webmaster is going to resolve the redirect of utm parameters. Thanks for the input all! – RobSource Sep 18 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.