1

I am setting up my organization's Salesforce instance to accept Leads from a third party system via web-service. Following are the steps I took till now

  • Created an Integration user in Salesforce.
  • Added third party's domain in Remote Site Setting.
  • Under Setup -> Build -> Create -> Apps I added a new Connected Apps and generated Client Key and Client Secret.

They are asking for endpoint URL. I gave them following URL

https://test.salesforce.com

They are still not able to make an authentication connection to Salesforce. Am I missing some other setup step? Is this the correct URL to use as the endpoint URL?

1 Answer 1

2

For Production endpoint is https://login.salesforce.com and for sandbox endpoint is https://test.salesforce.com/. If you are using OAuth for authentication then you have to send a request for authorization at https://login.salesforce.com/services/oauth2/authorize and then after authorization you need to send token request at https://login.salesforce.com/services/oauth2/token for production. Same will be the case for test environment except the endpoint will change.

3
  • Thanks for the reply @anmrk... However I am still getting the error saying "Salesfroce Login Exception: Authentication Failure - Invalid Password". I am manually able but with the request it gives the invalid password. error
    – Yash Mehta
    Apr 7, 2014 at 19:56
  • which OAuth flow you are using?
    – anmrk
    Apr 8, 2014 at 5:11
  • @anmrk.. I was able to resolve the issue, thr was a security token issue. Thanks for your help!!
    – Yash Mehta
    Apr 9, 2014 at 22:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .