1

I am trying to deploy a flow to a sandbox and I am getting the error

Property 'storeOutputAutomatically' not valid in version 48.0

The sourceApiVersion specified in my sfdx-project.json file is 48.0. The <apiVersion> in our package.xml is 47.0. However, this flow has contained the <storeOutputAutomatically> tag for the last month, and has not failed validation for this sandbox. The sandbox has not been refreshed. We have not made changes to the package.xml version or the sourceApiVersion in the sfdx-project.json file in at least a month.

Also, the documentation for the storeOutputAutomatically field on the FlowActionCall metadata type says the field is available in API version 48.0 and later: documentation

What could be causing this sudden validation failure?

  • what happens if you change apiVersion to 48.0 in package.xml as well? The error may be misleading. – Mohith Shrivastava Aug 27 at 23:41
  • I'll try that out and report back here, however the package.xml apiVersion and sfdx-project.json sourceApiVersion did not match before, and we did not hit this error up until today, deploying the flow to the same sandbox with the < storeOutputAutomatically> tag. – Delphine Aug 27 at 23:55
  • Just updated the package.xml apiVersion to 48.0 and it did not solve the problem, still getting the same error. Will file a case with Salesforce. – Delphine Aug 27 at 23:57
  • Can you add some sample metadata with which we can reproduce the error so we can hand off the bug to metadata API team? – Mohith Shrivastava Aug 27 at 23:58
2

We figured out the problem -- there was a subflow added to the flow, that had <storeOutputAutomatically>true<storeOutputAutomatically>. Prior to yesterday, the only elements that had the <storeOutputAutomatically> tag were record creates, record lookups and 'show toast' actions. We fixed the problem by checking the 'Manually assign variables' box in the parent flow that calls the subflow.

I guess storeOutputAutomatically is not yet supported for subflows.

Thank you for your quick reply and for looking into this, Mohith.

| improve this answer | |
0

The package.xml version must be kept equal to the api version specified in the sourceApiVersion to make sure everything is on 48.0.

If you are still getting exception then this might be a salesforce bug that needs more investigation.

UPDATE

storeOutputAutomatically is not yet supported for subflows as per investigation.

| improve this answer | |
  • We ran into this issue but seems like standard changeset deployment is not giving this error though. Any idea why package.xml deployment is throwing this error but not changeset? – srikanth pasupuleti Sep 13 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.