0

On Opportunity are two Custom Fields Product__c (controlling field) and Product_Type__c (Dependent Field)

When i check the field level security on these fields, it is visible for all Profiles. I want these fields to be not visible for ll profiles. However I am unable to edit the Field level Security.

enter image description here

Also, from Set up > Profile > Object Settings > Edit > 'search the custom objects', the checkboxes next to these two fields are greyed out. I do not want to assign these two fields to the profile.

I am wondering how can i edit the Field Level Security and revoke the permissions to these fields for the profile?

  • 3
    Are those fields marked as required on the object? – Mark Pond Aug 27 at 21:54
  • yes Mark, they were. I made them Not required on the Object, and required on Page Layout. Now I am able to edit the visibility. – user4947 Aug 27 at 22:21
  • 1
    Excellent. You should add an official answer here, to yourself, and accept it... so that someone who comes along later can see your solution. – Mark Pond Aug 27 at 22:41
1

Thanks to @MarkPond in pointing me in the correct direction. I was able to resolve this.

Steps to resolve

  1. Setup > Object > Fields
  2. Set Field Level Security
  3. Make the field not required
  4. Set Up > Profile > Object Settings > "Now the field is available for editing"
  5. Made the field required on Pagelayout
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.